Tag Archives: Sicherheitsupdates

Sicherheit geht bei LaMa-Creation vor! Serverumstellung dank guter Vorbereitung reibungslos abgelaufen. Seit August wurden alle Server Hardware sowie Software aktualisiert. Will man auf seine Server stets up to Date sein und auch den schnell wachsenden Sicherheitsansprüchen genügen, muss man ständig die Software auf dem Server aktuell halten.
Sicherheitsmängel werden hierbei beseitigt(Sicherheitsupdates). Auch die neue Hardware macht sich mit Schnelligkeit bemerkbar. Alle Server bei LaMa-Creation laufen nun ab PHP Version 5.3 als Voreinstellung. In neuen PHP Versionen kommen nicht nur neue Funktionen hinzu, unter Umständen werden veraltete oder unsichere Funktionen auch entfernt. Nun ist eine Migration notwendig. Das bedeutet, dass alle älteren PHP Skripte auf die neuen Begebenheiten angepasst werden müssen. Alle Webseiten wurden in einer Testumgebung ausführlich getestet, bevor diese umgestellt wurden.
Scripte, die unter der Version 5.3 laufen, sollten auch problemlos unter PHP 5.4 laufen. Alle Kunden,die veraltete PHP Funktionen nutzen werden benachrichtigt. Die veralteten Funktionen in der kommenden PHP Version, werden definitiv nicht mehr vorhanden sein! Eine Anpassung Ihrer Anwendung daher unumgänglich.

Hier noch eine Deprecated List:
http://www.php.net/manual/en/migration53.deprecated.php